MQA Playback & Support

…how did I miss this thread to start with??? Getting sloppy. but thanks for bringing it back up and giving me a chance to find more highly useful info.

There are two main MQA threads. This is the more specific one. The other is “General MQA Discussion” which is a bit more . . . philosophical.* **

*All proprietary formats are evil.
** Even when they’re really good, see first comment.

1 Like

We could probably end the thread with this.

4 Likes

Vic actually commented on one of my Reddit posts I had showing the NiBL playing in MQA mode, and shared this video with me. Figured I would post it here =) I am using Qobuz and Spotify premium now so I no longer get that delicious Magenta light :cry:

3 Likes

I just received a ifi iDSD BL that seems to be working fine (Dell XPS WIndows 10 laptop host). I also just signed onto Tidal High Quality (currently on 30 day free trial) account. I was trying to do some casual exploring of MQA. I followed the (not so professional) instructions from AMR on Youtube regarding setting up my Windows 10 Tidal app for MQA (although I never saw a ‘Playthrough’ option as referenced in the video)

I found some MQA content on Tidal and it played just fine. I was expecting to see a Magenta color on my iDSD but I saw nothing but green. So I found a couple of ‘stated to be’ MQA files that are downloadable for test (or whatever) purposes, and I played them through MusicBee. Green LED on the iDSD and MusicBee (and Windows Explorer) considers these files to be .flac files.

I know that the MQA format is built such that if ‘non MQA player’ plays these files they work fine viewed as just PCM files and can be played without an issue (somewhat lower quality). But it is like my Windows system is blocking the “MQA-ness” of these files. OTOH, both MusicBee and Windows Explorer sees one of these files as being flac and both 44.1 khz and 514k (at the same time-how can this be???). So somebody or something (I assume it is me) would appear to be really confused about all this.

I thought that I would ask here before I spent any more time here. This simply isn’t what I expected and seems wrong to me and I think that I am badly confused about something in this MQA space. Thanks.

dave

2 Likes

First make sure you have the MQA-enabled firmware installed on the iFi unit. I’m not sure what they do today, but when I reviewed the unit, the 8x DSD firmware was installed by default, which doesn’t support MQA playback. The MQA firmware enabled MQA playback but limits you to 4x DSD replay.

In the TIDAL application, under “Settings”:

  • First, make sure “Streaming Audio Quality” is set to “Master”.

Then under “Settings” -> “Sound” - > “Sound Output”:

  • Make sure you’ve selected the iFi DAC as the output (rather than making it the default system output and selecting that).

  • Then click “More Settings” and ensure that you have “Use Exclusive Mode” enabled “Force Volume” enabled and “Passthrough MQA” DISABLED.

Yes, it seems counterintuitive to have to disable MQA passthrough, but the iFi unit needs TIDAL to do the first unfold of the MQA file, which is what leaving “Passthrough MQA” disabled does (if you enable it, it doesn’t do the first unfold - which is a setting you only use with a DAC that can do full MQA decoding - which isn’t the iFi unit).

Anything that changes the MQA data stream will result in the file not playing as MQA. Which means no software volume control (hence “forcing” max volume in the TIDAL app), no software EQ, and no playing a mixed, MQA/non-MQA stream (which is why you want Exclusive mode on).


Another note … while MQA files are packaged as .FLAC files when you stream or download them, if your music player software does not support MQA Core Decoding (“the first unfold”), then you will not be able to play them as MQA files with the iFi DAC.

The only players that I am sure support MQA Core Decoding are the native TIDAL client, Roon and Audirvana+. There may be others, but I’ve not tested them.

ALL music players that can operate in bit-perfect mode should be able to play MQA files to a DAC that supports “Full MQA Decoding” (i.e. the DAC hardware also does the first unfold). But, again, that’s not the iFi stuff except, fi they’ve finished the firmware, the Pro iDSD.

Note that with your music player software doing the first-unfold, and the DAC doing the rest, the end result is FULL MQA decoding … it’s just a different path to get there.

2 Likes

Torq, thanks again for the very helpful response. This filled in a # of blanks in my mind.

I did successfully enable MQA via the Tidal app. What the ifi youtube video referred to as the ‘Gear’ selection is now a unhighlighted ‘more settings’ test string that leads to stuff like the Playthrough, etc options. From there I got MQA working.

And per your input I would judge that MusicBee simply isn’t a ‘fully MQA ready app’.

dave

3 Likes

Anybody got Masters to work with their iPhone yet?

Yep. See my note above at about post 27

I have camera adapter. I must have MQA capable dac to do it? On my computer I get the 96k master. When I use iPhone with camera adapter to my SMSL SU-8, I do not get 96k but only 44.1k.

I really don’t know.
** Idle speculation follows:**
I would think that an MQA DAC would be what you need, but I distrust what I see in complex apps, especially in the first weeks they’re out. I have only tried with the DFB and the xDSD, both MQA capable, not with my older TEAC DAC.

If your DAC is not MQA capable, then you would have to hope that
a) the iOS App is performing the first unfold (only, can’t do better) and
b) your camera card + non-MQA DAC is allowing you to extract higher resolution sound than the lightning choke point.
------ and I’d wonder
c) what quality sound is coming out of the headphone jack if I had one?

This I do know:

  1. without the camera-card/DAC combo you can’t get anything higher than 44.1K out, ever
  2. With that combo, I have been able to play high-res non-MQA files at correct resolution
  3. With camera card + MQA capable DAC, I was able to get the MAGENTA lights showing MQA using the Tidal Master. I do not recall having to set the app for the app to do first unfold, and the DAC to render (like you do with ROON and the desktop app)
  4. The iOS app is different than the Android App, which will do the first unfold on the Android device (at least under Android 8 (“Dubious Marmelade”) which I am using. So lessons learned with the Android app may not apply.

@Torq and others, your experience?

3 Likes

When I tried it, using the Apple Lightning to USB 3.0 Adapter and the AudioQuest DragonFly Red, and the latest TIDAL application, I was able to get MQA playback from my iPhone XS (magenta light on the DFR) with no special gyrations.

I just fired it up using the same adapter into a Chord Hugo 2, and that shows 96 kHz (etc.) for MQA content and 44.1 kHz (etc.) for non-MQA files, which is also what I would expect. Again, no special configuration needed, as long as the file is MQA and the “Master” streaming option is selected.

The TIDAL application on the iPhone doesn’t have much in the way of configuration. If the Streaming setting is set to “Master”, which is must be for MQA files to play (as MQA) it appears to always do the first-unfold for you unless the DAC advertises that it can do full MQA-decoding. There is no setting to change like there is with the desktop application.

If the SMSL SU-8 isn’t showing a higher bit-rate then I would wager it is device-specific issue. Not all USB-DACs correctly advertise their capabilities, and in this case I don’t know what the SMSL unit does - nor how it interacts with the necessary Lightning to USB adapter.

3 Likes

Do you see the master button on the screen when you play it? At the bottom of the screen where Current song playing is main view? Does it say master or hifi?

It shows “Master”. This is a screenshot just taken on my iPhone XS, latest version of iOS and TIDAL, using a standard Apple Lightning to USB 3.0 Adapter into a Chord Hugo 2:

And, again, the sample-rate indicator on the Hugo 2 shows the correct (96 kHz for this track), sample rate.

1 Like

Very interesting. I don’t get the Master ever there. I only get HiFi. Latest version.

“Master” shows up for me with MQA content even without an external DAC or headphones connected (though the iPhone audio system will actually downsample that to 48 kHz for playback on the internal speaker). So I would work on getting that working before worrying about an external DAC.

Beyond that:

  • Which iPhone, what version and what version of iOS?

  • Which Lightning to USB Adapter (I don’t know if the old “Camera Connection Kit” cables still work for this).

  • Do you have “Master” enabled in ALL your streaming options in the TIDAL app?

  • If you’re streaming over Cellular not WiFi, is that set to “Master” as well? And if so, do you have “Optimized Playback” turned OFF?

  • If you’re playing local downloads, if they were downloaded in HiFi mode you’ll need to make sure you set the “Master” option in the downloads section, then delete the file and re-download it to get the actual MQA version.

1 Like

Iphone XR with ios 12.2.2, tidal 2.7.2 build 1934. I have the Lighting to Camera Adapter (but still not seeing master when that’s not connected), turned off optimized playback, put master on all options (just to test), redownloaded and downloaded albums, turned off downloading by cellular just to eliminate that factor. No matter what I’m still not seeing “master” button at bottom.

1 Like

No idea then, short of deleting the TIDAL app entirely and re-installing it or the actual file you’re playing not being an MQA file (if it doesn’t have the “M” icon, then it’s not MQA and won’t play at anything but it’s normal 44.1 kHz rate). But if it won’t work directly on the device then it’s clearly not the camera adapter or the DAC.

I’ll try the redownload and download again for Tidal app in the next day or so and report back.

I deleted and redownloaded tidal today. It’s working now and showing 96k through SMSL SU-8 and the master button on tidal app.

2 Likes