Weird iPhone Xr CCK - DAC problem


Thanks for a great forum!

I am having this strange problem when trying to connect my iPhone Xr to my new JDS OL DAC through the Camera connection kit and a Forza USB cable.

Nothing happens.

My iPhone charges as normal and I can connect to my headphones via the lightning - minijack dongle. But it is as if it does not register the connection with the dac. I have tried with two different USB cables so I am assuming that the iPhone is the problem.

My son’s iPhone SE and my girlfriend’s iPhone 7 both connect without any problems.

1 Like

That does sound like it’s the phone, though I don’t see why.

Do you have another dac to test out?

1 Like

I think I located the weak link in the chain (from JDS’ website):

"* Make sure you are using a genuine Lightning adapter. The following model is supported:

JDS Labs has confirmed DAC support for iOS versions 7.x through 11.x (most recent build as of January 2017). Customers have reported DAC connectivity success with iOS 7.x, 8.x, 9.x, 10.x, and 11.x. Please note that support is dependent on the mobile operating system and can vary with each operating system update!

The older Lightning to USB Adapter, part #MD821AM, may be used with iOS 7.x thru 10.x, but does not support USB Audio when used with iOS 11."

Damn you Apple!


Of course!

Apple and their more expensive connectors…

I use the DFC with the same adapter you’re using. Fortunately it’s worked out okay (iPhone XS Max).

I’m glad you figured it out.


1 Like

Worst… And their proprietary connectors :wink:


I’m glad they’re moving to usb-c. It’ll make things much easier. :+1:t4:


+1 This, it was one of those things I hated about them.

1 Like

Actually, they’re not moving the iPhone to USB-C.

iPhone 12 will still be using a lightning connection. After that, it’ll be a proprietary all-wireless/socket-less design using a variation of the flush magnetic connector as seen on the iPad Pro.


Well, that’s another 50$ spent. But at least it is working now.

The show isn’t over before the f** lady sings…


Are they going to drop the usb-c from the iPad Pro’s?


Totally different use cases.


Well that’s a bummer as far as the iPhone is concerned.

I’ll have to find an alternative to DFC by then.

Well that’s some unwelcome news. I have both connectors, and most often used the powered one, but when I’m looking for pure portability, I use the older connector and a DFC with my iPhone 6+ (yes, I know the 6+ is very old, almost the wall phone of iPhones). When I upgrade to one of those new models, I’m going to lose both the headphone jack and use of my old camera adapter.


I have XS Max and I’ll be in the same boat come time to upgrade ( though my upgrades are more of a 4 year cycle).

My son is currently using my old 6+ which I think I’ll reclaim in the near future (I think we’re getting him an SE) and use it as an “iPod” to pair with the DFC, and potentially a more powerful portable dac.

1 Like

Very interesting to hear about your experience with the Dragonfly Cobalt and Apple’s lightning to USB adapter. When I tried it with my DFC and iPhone SE (first gen), I would hear clicks and pops while playing music. Swapping it out for the lightning to USB 3 adapter made the clicking sounds go away.

After reading the (Mis)Understanding USB Audio thread, I’m starting to wonder if some of the regular lightning to USB adapters just aren’t up to code.

The only issue I have with the adapter aside form it’s lackluster build, is that if I type within another application during music playback, it seems to confuse the DFC and it can distort. As though it has to choose between the music and keys clicking, if that makes sense.

Oh that’s pretty strange. I would expect the two different audio sources to be mixed in software before being sent to the DAC. I just tried it with my DFR and didn’t get any distortion. What app are you using for playing music? I was just using the built-in Music app.

1 Like

I typically use Tidal, and Apple Music. But it occurs with any app. including video players such as YouTube.

Hmm, in that case I’d guess it’s either due to a difference in our phone models, or somehow it actually is the adapter. The USB 3 adapter is a little different since it has firmware running it. It’s just unfortunate that the USB 3 adapter is so large and clunky.

1 Like

Agreed. The usb 3 is so clunky, but if it works. :man_shrugging:t4:

For reference I’m using an iPhone XS Max, and I’m also using it with an iPad Pro 12” (1st gen). Same results with the iPad.

1 Like