DLNA/UPnP & Metadata

I searched for a relevant thread for this but couldn’t find one. That doesn’t mean it doesn’t exist, just that I failed to find it. If anyone knows of a relevant thread, please let me know and I’ll merge this into it.

So, there are various places in my house and work where I use DLNA to play music from networked drives.

My networked drives are actually PCs running Windows that share the drive (and have the relevant permissions set up etc. or at least I am pretty sure they do).

On these networks, I can use BubbleUPnP (and other similar apps) as a controller and send the music to the renderer of my choice. However, for some reason, BubbleUPnP doesn’t recognize the files directly.

As a workaround, on the same PC that hosts the shared drive, I run a dumbed down version of Kodi that just indexes the files and this allows them to show up in BubbleUPnP. It’s not the cleanest of systems but it works without issues.

However, I also have a portable 2tb drive that I use attached to a Ravpower Filehub+. The Filehub has a built in DLNA sharing service which allows me to share the music in much the same way when travelling or away from home/work (at the beach house etc.).

The problem is that, while BubbleUPnP sees the files and can play them without issue (sending them to a renderer of my choice, or even in the local player), it does not see any of the Metadata.

All of the tracks appear as “Unknown Artist”, “Unknown Album”, “Unknown Track” etc.

I can browse the folders and play them direct from the folders, which are arranged in Albums anyway, but no artwork shows up (or any other data), it just shows the name of the file and treats it all like one big artist and one big album (with lots of tracks).

If I use UAPP, it has exactly the same result. Everything is available but no metadata is shown.

Now, the weird thing is that the information is actually there. If I open the metadata information of a track in UAPP, I can see the data, but it doesn’t use that data in the library. In BubbleUPnP it doesn’t show anything even when inspecting the individual files

Here are a few photos to explain (some bits are in Spanish but I don’t think anything relevant is missing).

This is in BubbleUPnP:

And here is the same process in UAPP:

So, any ideas or tips on resolving this, or even any further troubleshooting steps?

1 Like

I should probably note that if I connect something to my portable network and run Kodi on it (a cellphone, Pi, etc), this solves the issue and metadata becomes available, just like on my home/work networks.

However, carrying an extra device just for this is a pain in the …

Short version, you need a proper DLNA/UPnP host - not the half-assed/buggy implementations often built-in to multi-purpose hardware.

That will be responsible for indexing your files and making the navigable metadata available, as well as serving the files to the DLNA renderer. The control point just reads the published metadata from the DLNA service and sends a list of files to the renderer to play - which then transfers them from the DLNA server (i.e. they are not exposed to the renderer via a file share in a proper DLNA/UPnP setup - it’s more like a special FTP protocol).

At home, just put something like Asset UPnP (for which there is a free trial) on the box hosting the drives.


Thanks Torq. Asset UPnP is actually a very reasonable price also.

I guess for portable, I’ll just make do with folder exploring and no pretty pictures.