Issue with FLAC stored on NAS and Android devices

I am not sure if any of you will be able to help but I have spent a fair few hours trying to resolve the issue I am having without any luck.

I have my music collection on hard drives connected to a router, sharing via smb but also with a DLNA server activated.

I am trying to set up either an android device (running UAPP) or a DAP (M2X) connected to a DAC as a upnp renderer.

My issue is that any of the upnp control point apps I use, they fail to see the flac files on my NAS. They can see and play all mp3 files, they can see movie content, image content, and even the full folder structure, but once I open a folder that contains flac files, they all say that the folder is empty.

I can access all the same flac files from file explorers on Android and I can even play them without issue in local playback apps, such as UAPP on the device. However, any app that is capable of upnp control (such as Bubble Upnp, Hifi Cast etc.) fails to see any content in the folders.

My aim is just to be able to wirelessly control a device that is connected to a DAC by means of another android device. My preference would be Tablet (running UAPP) > DAC > Amp and control the UAPP playback from my phone.

Any ideas as to what the issue may be?

Many thanks in advance!

Just checked this with my Pixel 3 XL. BubbleUPnP (which I haven’t used much since I moved to Roon for my home music network) sees FLAC files on my Synology NAS.

Are the hard drives actual NAS devices (connected to your network via Ethernet) or are they USB devices directly connected to your router?

If the drives are actually NAS devices, what specific brand/model?

What brand/model router?

What specific DLNA server are you using?

Usually this sort of issue, where one media format is visible and another isn’t, turns out to be that the DLNA server doesn’t support it - which is a lot more common if that server is running on a router or NAS box than if it’s running on a PC or Mac.


They are connected to a router

TP-Link TD-W8970

The built in one on the router. I have file sharing activated (SMB based) and al Media Server activated (no specific details outside of it being TP-Link’s software built in).

I have actually had this issue in the past with specific files or formats not showing up, however, what is confusing me in this particular case is that the (FLAC) files show and can be played when using any app that is playing locally. For example, they show up fine in UAPP and can be played locally (through a DAC etc.), they just don’t appear in upnp control apps.

I can also find them (the FLACs) in a file explorer and open them in any app that shows in the “open with” list, but non of the upnp control apps appear in said list (and it is also a PITA to do it this way).

SMB and UPnP/DLNA are different services. Your Android device may see a FLAC file via SMB, but the UPnP/DLNA service may be buggy or misconfigured and now show the same file.


Maybe that is the issue, that the upnp control apps are looking to connect via upnp/dlna and the local players are accessing via SMB.

It’s almost certainly what it is.

Embedded Media Server apps, even those with name-brand association, are rarely properly current. The stuff on, say, an actual Synology NAS device works fine. Some of the Drobo options work. Most the others are a crapshoot.

So …

I would suggest downloading the free version of Asset’s (of dbPowerAmp fame) UPnP/DLNA server*, pointing that at your music folders, and then when it is done indexing, if the file count looks right, re-trying your UPnP/DLNA control point.

(@earnmyturns has a very nice system that is primarily fed by either DLNA or Roon … though I don’t know which way he drives it … I have the same system, excepting the speakers, and I actually use both DLNA and Roon with it, depending on how I am listening).

*It’s available for both Windows and macOS, there’s a 30 day trial, a free edition, and paid version that adds some features missing in the free version (folder-browsing being one, if I recall).

1 Like

Thanks Torq, although I did move away from having a dedicated server on 24/7 because I got tired of it, Asset’s would involve me going back to having a PC active.

To be honest, with my PC on, I can already use Foobar or other software to send to my upnp renderer’s (I use the M2x that way a lot) without issue.

I guess I will have to go this route though if I want the commodity.

Just a remote app to control UAPP would be perfect :wink:

I was only suggesting using Asset as a test … since it is a quick and easy way to see If the issue was the Media Server on your router.

1 Like

Sorry, I misunderstood you.

I just pulled out my Linux machine that I used to use as a server and will give it a twirl to see if it cures it.

1 Like

I know you don’t want yet another server around, but trying to coax an Android device to serve as a network streamer is going to be an exercise in frustration, Android is not really designed for that use case. In your shoes, I’d get a teeny, fanless Raspberry Pi-based streamer running one of the audio-oriented Linux distributions. Since you seen to be using an USB DAC, this would fit the bill. Or this, you want something more turnkey (and a lot pricier) with WiFi built in.

I was testing things out until the early hours last night.

I tried Asset UPnP but I couldn’t get it to connect with my networked drives at all (the whole drives, not just FLAC). It worked perfectly with local hard drives connected via USB. This is obviously due to user error as it is a while since I used Ubuntu (I didn’t even realize that it now has a software installer function until after I had installed most of the stuff via terminal).

I also tried Gerbera but I could not get the browser UI to run. Again, user error, but it was getting late and I was probably not in the best of my capacities to fault find.

Finally I just gave up and installed Kodi (another program I haven’t used for quite some time).

I pointed Kodi at only the folder containing FLAC files and once it had loaded them to the library (and I had set the correct UPnP permissions) all the android devices and UPnP control apps could suddenly see the FLAC files without issue. All FLAC files appear now under the Kodi UPnP server and all other files (MP3, video, images etc.) are available directly from the drives (via the router).

That was a positive enough point for me to call it a night and go to bed :wink:

I am out with the family today (for some reason they are not interested in Linux and UPnP lol) but I will start working on a permanent solution when I get some time later.

I have a few Pi’s sitting around doing nothing so I may just set up something simple (like OpenELEC) but I will see where it takes me. I also have another laptop that has WOL and my 4tb of storage drives connected to it that I use as a backup system for all my (non-media) files but I like to keep those separate and offline unless I need them.

Anyhooo, thanks for the help so far and I’ll spend some more time later.


Just as an update…

Last night I was digging out a Pi when I came across my box of Android devices.

I installed Kodi on an old Android phone (running Android 7 with 3gb of RAM) and it seems to function the same as having Kodi on a laptop.

The phone just seems to be acting as a guy shouting “Hey, your files are over there” :smile:

1 Like