Mytek Liberty DAC

I recently bought a Mytek Liberty DAC to replace my Schiit Modi 2Uber DAC & Magni 3 Amp. My Schiit combo was a great value, but only PCM. I had an itch to try Roon/Tidal/MQA and DSD files for my Sennheiser HD 600 and Focal Elear headphones. My problem is the left indicator light (MQA/DSD) on the Liberty DAC – it’s always orange which indicates PCM. No matter if I play PCM or DSD or MQA, it stays orange. The manual says it should be White when playing DSD and Green when playing MQA. The manual is no help. Email support (from Poland) is worthless. Am I screwing up my settings in Roon? Do I have a bum DAC? Does anyone else have problems? This DAC sounds good, but am I missing MQA and DSD? PS: MQA sounds good. DSD files don’t play – silence – via Roon. All from my iMac and USB to the DAC. Thanks for the help.

1 Like

Some others on here can probably help you in more detail but I believe it’s probably the settings in Roon/Tidal if you haven’t already set them to do an MQA pass through (or indicate the output device is MQA capable) otherwise it’ll decode and output PCM to your DAC. Tidal it’s under the streaming settings on the desktop app (need to use the desktop app). Roon, I believe it’s under the settings for the output device. (I’m at work at the moment so not looking at either application to be exact).

3 Likes

Assuming Mytek haven’t done something irretrievably stupid, the settings I’d expect you’d need in Roon (macOS via USB) are as follows:

In Roon, go into “Settings” -> “Audio”.

For the devices listed under “Connected to this Mac”, click the “gears” symbol next to the entry for your Liberty, and choose “Device Setup”.

  • Set “Exclusive Mode” to “Yes”.

  • For “DSD Playback Strategy” choose "DSD over PCM v1.0 (DoP).

  • For “MQA Capabilities” select “Decoder and Renderer”.

  • For “Volume Control” choose “Fixed Volume”

  • Click “Show Advanced” at the bottom of the page.

  • For “Enable MQA Core Decoder” choose “No”.

  • For “Enable Integer Mode” choose “Yes”.

That should be all you need to do. I’m not sure why choosing “Decoder and Renderer” for “MQA Capabilities” doesn’t automatically disable “Enable MQA Core Decoder” (maybe it does, but only if you don’t look at the advanced settings), but that’s what you need to do.

DSD files should now light up the indicator in white.

MQA files will be either green, or blue (they should be blue if they’re coming from TIDAL). MQA albums will show up in Roon as having “MQA” (and the MQA bit-rate) next to the format information under the album art in album view. If it doesn’t say MQA there, then it won’t show up as MQA on the DAC.

7 Likes

Welcome @Hoyt_Maulden. Excellent first post.

2 Likes

Hey Torq,
It’s not often I talk directly to a “celebrity.” Thanks for all your work on behalf of the Headphone Community.

(“Irretrievably stupid” will probably apply to me, not Roon, as I am a card-carrying Luddite.)

Rather than burden the whole Community with my travails, I thought you might indulge me with a one-on-one consultation?

Thanks.

I enacted the settings you recommended below. The result:

  • Able to play DSD files now for the first time — I can at least hear them. Yay! But (1) Roon Path shows “DSD to PCM conversion (DSD64 to 352.8kHz PCM).” I thought I was going to be able to play “Native DSD” with this DAC, with no DSD conversion to PCM? Not true? MYTEK MARKETING SAYS LIBERTY PLAYS “NATIVE DSD”. (2) the MQA/DSD light on my DAC is still Orange (PCM) when I play DSD/DSF files. (Makes sense if I am playing DoP and not Native DSD. Hold that thought.)

  • When I play Tidal/MQA (without Roon) it sounds pretty darn good, but the MQA/DSD light/diode is still Orange. Not Blue or Green as for MQA.

Notes: When I launch Tidal I get this screen. And when I play an MQA track, the “MASTER” indicator lights up in the lower right corner of Tidal app.

When I launch Roon and play the same MQA song, it sounds fine, but my Liberty DAC MQA/DSD diode is still orange.

The Roon Path shows:

Does all this look OK?

Important Note: Let’s start at the beginning. When I contacted Mytek Support via email, I pointed out that their Liberty DAC was not one of the selectable (default) choices in the Roon list. (THIS IS IN SPITE OF THE MYTEK MARKETING WHICH SAYS THE LIBERTY DAC IS “ROON READY VIA USB”.) Anyway, Mytek support suggested I select the Mytek Brooklyn DAC as my default, since it is the closest config to the Liberty. I have tried both ways — selected as “Brooklyn" and also as “Unidentified Device” that I labeled “Liberty DAC”. Same result both ways. Light is always Orange.

May I backup a bit? Let’s start with simplest problem first. Playing MQA on Tidal, without Roon. There is that pesky Mytek App that is such a mystery:

First thing I did was to download the new firmware — to 1.35. Fine.

Now look down below/right at the “MQA/DSD Diode” button. I have tried both settings here — Always Active and Auto Off — with no change in operation. Either way, the MQA/DSD diode light always stays Orange when I play anything.

Next, how about my pure Tidal settings? Do they look OK?

Is this right? YES for both Exclusive Mode and Passthrough MQA?

So, thanks to you, I can now play DSD files via DoP. THANKS. Just not Native DSD. But my Mytek diode is still Orange for everything, including (1) MQA (with and without Roon) and (2) DSD using Roon.

Any help would be appreciated.

I paste below my Roon settings screens in case I have screwed them up.

Thanks for your efforts on my behalf.

Hoyt

Fredericksburg, VA

1 Like

Let’s start with DSD first:

In “Device Setup”, “Advanced”, change the “Max Sample Rate (DSD)” to "“Up to DSD256”.

I’m guessing that you’re trying to play a DSD256 file, as there’s no other reason for Roon to output PCM with those settings. What it should say when you click on the “Signal Path” is: “Encapsulation” [DSD over PCM v1.0 (DoP)":

DSD over PCM (DoP) is still “native” DSD (that’s such an abused and bastardized term)!

DoP is just a way of sending the data using PCM data-frames. The actual bit-level data is 100% unchanged. It is NOT converting DSD to PCM using DoP if its setup correctly.

Again, I think the issue you have there is you have the DSD max sample rate at 128 and are trying to play a DSD256 file. And that would have to convert to PCM. But since Liberty supports DSD256, that’s the setting you want in"DSD Max Sample Rate".

If that doesn’t work, and all the other settings are as listed, there’s something else going on.

Now for MQA:

First, in Roon, you MUST change the “Enable MQA Core Decoder” under “Device Setup”, “Advanced” to “NO”!

And you must ALSO make sure you have no EQ, DSP, software volume control or any other filters set up in Roon, as that will 100% defeat the MQA authentication encoding.

In TIDAL …

Set the “Force Volume” to “ON”.

ANY software volume control, either from the TIDAL client or macOS will stop MQA from decoding/authenticating. Same thing if you run something like Sonarworks or other system-level EQ.

1 Like

Torq.
Thanks for clarifying “DSD over PCM (DoP)” vs. “Native DSD." So there is no difference.
But, no luck yet with my Liberty DAC.
(1) Roon: My max DSD sample rate only shows “Up to DSD 128.” Which I had selected. Now, playing a DSD64 file results in no sound at all. I am not able to play any DSD/DSF files. No sound. Even playing Roon DSD64, or DSD128 I get no sound. Ugh.
(2) MQA & Tidal: I changed settings to your recommendations. Sounds darn good, but still only Orange on my Liberty DAC MQA/DSD light.

I am going to borrow a Mac laptop and see if things are any different.
I would live with the MQA sound quality without the White light. But, I need to figure out what is preventing playing any DSD files – DSD64 to DSD256.
Meanwhile, I really appreciate your assistance.
Hoyt

1 Like

Well, unless the Liberty isn’t a full decoder/renderer (as far as I know it is), or you have some volume control in software/on the PC/Roon/TIDAL going on, the MQA part doesn’t make any sense.

Neither does the DSD … though picking a generic device and setting that up might be a better way to go than choosing the Brooklyn device.

I don’t have a Liberty, nor know anyone that owns one, so I can’t poke at it myself.

It’s possible it’s a wonky unit. But it’s more likely that there’s a setting somewhere that’s not right. Really hard to say as I don’t know who the overall system is setup, there are just so many potential variables at work. But the Roon and TIDAL settings should be what I gave you.

Sorry I can’t be of more help.

1 Like

One thing you may want to try is setting the MQA capabilities to just “Decoder” vs. “Decoder and Renderer” in Roon and see if that works.

1 Like

I’ll get another laptop into my setup tomorrow and update you.
Thanks for the help today.

“Decoder-only” doesn’t work. But thanks for the suggestion.

I just bought my first DAC - Mytek Liberty - and it’s sounding a bit thin and edgy to me when played trhough my system(not headphones). I’ve been unable to find how to use the desktop app to adjust the DAC (though I did discover how to raise the output volume by accident) and don’t want to fiddle before I know what I’m doing. Any suggestions? Is there a site I’m overlooking that explains how to use the app? Am I simply not used to the DAC which is why it sounds thinner and edgy?

Also, I have a Pass HPA-1 headphone amp which contains a pre-amp. Should I run the DAC through that into my stereo for a power boost? I’m thinking DAC to Pass to integrated amp?

Sorry if these questions are too basic but any help is appreciated.

Thanks

1 Like

That’s generally been my impression of Mytek’s DACs; without knowing what the rest of the system is its hard to say more than that.

Are you talking about the “Mytek Control Panel”?

I see no manual for that on Mytek’s support page. If there is no built-in help for it, check the install folder for a PDF or TXT file. Otherwise submit a ticket to Mytek and see what they say.

Depends on what you were using as a source before, what your overall system is, and so on. It could just be that’s how it sounds in your setup, or how it sounds period.

No, don’t do that.

Your integrated amp should already have a pre-amp in it (as an integrated amp is defined as being an amplifier that has both a pre-amp and a power-amp in one chassis). Adding another stage of amplification before it will just add noise and distortion, and possibly overload the headroom on the inputs on the integrated amp.

1 Like

As @Torq said, try the Mytek Control Panel.

You can find the version for the Liberty here. https://mytekdigital.com/professional/support/

Direct Windows link here: https://mytekdigital.com/download_library/control_panel/MytekControlPanel_v.1.50.zip

1 Like

Thanks all… I should have clarified that I’m running this from a new MacBook Pro through a Plinius integrated amp. I’m using upgraded interconnects and a Pangea power cable and using JRiver Media Center. Speakers are custom-made by Van L. Speakerworks in Chicago and I’ve really enjoyed the sound of the system prior to this upgrade. I also relied on Pono (which is why I went with JRiver) and the portable Pono device had a much rounder and more full sound when connected to my system. Not sure if this is just a change I need to adjust to or if I have to get a different DAC. I’ll try tinkering with the Mytek controls a bit but I still have been unable to find a source that tells what all the tabs etc. do

I’ve been meaning to try out the Liberty DAC for a while now and we finally have one on the way from Mytek on it’s way to our office. With a Brooklyn DAC+ to follow shortly after that. Looking forward to trying giving it a try as I’ve enjoyed our time with the Brooklyn Bridge (although @andrew has been doing the majority of listening as of late).

We’ve got a couple Amp / DAC combos in the office right now from various price ranges so it would be good to do a run through of them all.

2 Likes

Been loving my Mytek Brooklyn Bridge. It feels end game for me for dac amp streamer.

1 Like

Great video. When I first started out on my headphone journey the Mytek Liberty was one of the units I was looking into.

I’ve read a few places that the Liberty does really well with an external power supply. I wonder if you have one around to test this out? I believe ifi makes a 12V option for their iPower line.

3 Likes