Connecting ipad pro to dac/amp

Thank you. Question will be then waiting for a firmware update. @robmcmyers ’ posting of the TidBITS article made my head hurt - or at least reminded me of things I’d read before.

In any case this wire - cheap generic 0.8m with confusing logo and no other markings did not work

Tomorrow, I will try this one that I carry in my MacBook travel pack.

That is a passive half-meter cable. It should be high enough spec that if something isn’t working, it’s probably the Sabaj.

So, @Torq, If I understand you correctly, all the Dragon Tail is really doing is slowing things down and/or forcing backward compatibility to USB-2? Would you be aware of something more esthetically pleasing than the Dragontail to USB-A and A back to C?

LATER NOTE: In the office, I looked at the other cable that did noting. It has the SS20 label, so it should have been OK.

I see a driver on the Sabaj site I will post a question on the Sabaj thread here. As usual, I suspect you’ve nailed the issue. Dankashein.

I don’t think you’re going to find a USB-C to C cable that will work …

The DragonTail maybe doing a simple USB-3 to USB-2 “step-down”, or it may be in an OTG configuration (@SenyorC ran into something similar recently with a HiFiMan DAC/amp, which I suspect was also using an XMOS solution for it’s USB input).

I suspect the real problem is Sabaj not using the XMOS capabilities correctly and then failing to be clear about what works or doesn’t in any product literature.


Thank you. To be fair, the product literature only speaks about computers; says “driverless” for MacOS 10.6 and above, and Linux. For windows a driver is required, and I’m guessing that the driver on their site is for Windows. I’ve sent them an inquiry.

There are reports of it not working with Macs also, so I’m sure they’ve borked something. It’s clearly not just an issue with phones/tablets.

If they say “driverless” for macOS, why would they provide a macOS driver?

I sent them an inquiry about a firmware update for the USB port, not about the driver on the site. Sometimes my thoughts run ahead of my typing fingers.

Since I’m at a computer, I can type a more detailed response because I have several questions about the Sabaj A20D 2022, cables, and adapters that I could not answer despite my use of Google (mainly because I don’t have access to them):

  • Do we know the Sabaj’s USB specification? The A20D 2022 product page makes no mention of a USB spec, while the A10D 2022 product page mentions USB 1.1 and 2.0 asynchronous. The earlier A20D used a USB Type-B (pre 3.0*[edited from pre 2.0]*) connector.

  • Do we know the Dragontail-C’s USB Specification? The product page does not mention USB 2.0 or USB 3.0. Some retailers state that it is compatible with both USB 2.0 and 3.0, but what does that actually mean? Is it true?

  • What does the USB-A end of the included USB-C to USB-A cable look like? How many connectors can you see, 4 or 8? Page 78 of the USB Type-C white paper from 2019 shows the pinout of a USB-C to USB 2.0 standard-A cable. Page 77 shows the pinout for a USB-C to USB 3.1 standard-A cable. Notice the additional pins with the USB 3.1 standard.

Per page 31 of the white paper, USB-C to USB-C cables come in several varieties, including a USB 2.0 to USB 2.0 cable and a USB 2.0 to USB Full-Featured. If you could try out your device with one of those cables, we might learn more about what it is that the Sabaj A20D 2022 is doing (or is not doing).

Based upon by other users’ experiences (unable to get the device to work with multiple different USB-C to USB-C cables, Mac laptops, and Windows laptops), Sabaj could have used a physical USB-C port but is not implementing the USB 3.0/3.1/3.2 standard. This could be due to software/firmware issues, or it could be that they didn’t attach the USB-C port with all 24 pins connected.

1 Like

Actually, we do know from Audioquest that the DragonTail operates in USB-2. What we don’t know is if it is simply stepping down USB-3 to USB-2, or if it’s also doing an On-The-Go cable conversion. See comments from @Torq above.

Ian also suggests that the Sabaj XMOS USB implementation needs at least a firmware update. I’ve written to Sabaj asking about this. I’m aware of the USB cable issues, and the SS20 cable I used yesterday (also tried a basic cable) should have worked if the Sabaj USB had correctly implemented the spec. We know the Apple iPad Pro is properly implemented. I have a half-meter passive USB-4 40gb spec cable to try (USB-3 ends) but given that even the USB-3 SS20 should have worked, I’m not expecting the USB-4 to work.

Later note: I confirm that the USB-4 cable also does not work, Only the DragonTail solution.

1 Like

The issue is specifically with direct USB-C to USB-C connections.

Don’t know of any iPads that still have Touch-ID and a Home button that also have USB-C.

The minute you have a Lightning or non-USB-C connection on the source end, the problem will not be apparent.

Also, Buena Vista Social Club is a favorite album, and the 25th anniversary edition didn’t actually ruin anything.

But see @Torq 's comment about USB-C to USB-C. My half meter USB-4 40gb cable didn’t work, and I know that’s a good cable. But if @SebastienChiu wants to send me an iFi USB-C to USB-C cable to test, and it works, I’ll be happy to buy it. But I think @Torq is right.

Congratulations! I hope the recovery is swift.

During my lunch hour, I decided to take a closer look at the Apple USB-C cable that I am using with my iPad Pro (11-inch) (3rd generation). It is the cable that it originally came with - not an aftermarket or 3rd party cable.

Interesting enough, it does not have the full complement of pins, instead having the following pinout (1 indicates a pin, 0 indicates a gap):

Top row: 100101111001
Bottom row: 100111101001

This suggests a USB 2.0 and Power Delivery configuration. After doing some additional digging on Apple’s website, I found a support article that while the Apple Thunderbolt 3 (USB-C) cable supports Thunderbolt 3 and USB 3.1 Gen 2 data-transfer speeds, the Apple USB-C Charge Cable is limited to 480Mbps (USB 2.0).

If the Sabaj’s USB-C port is operating only at the USB 2.0 specification, perhaps the Apple USB-C Charge Cable 2m would provide a means to connect it directly to the iPad Pro?

I have the M1 iPad Pro. I don’t recall if there was a charge cable with it. I think Apple might have been getting cheap. I don’t think any charger was included.

1 Like

There was all sorts of confusion regarding Apple’s USB-C cable specs in the early release days, as suitable for power supplies versus high speed video/drive data. Apple is arrogantly cheap with its cables and has been for 20 years. The cables all break at the connector, and the connectors are slick so they can be impossible to remove.



Sadly, the primary reasons for it are, for those devices:

  • Vendors that don’t implement USB-C correctly.
  • Users that would rather pay for a dongle than buy a new cable.
  • Devices that aren’t USB-C in the first place.

It’s a shame that, 8 years since USB-C was ratified both cable and device vendors are still half-assing their implementations. Though the USB-IF is, I feel, as much to blame for the situation … since it doesn’t seem to be very well policed as a standard.

1 Like

As I’m in the process of wrapping up with iFi and we are already deep in that,I, unfortunately, won’t be able to help with this one! So sorry!

Looking around the net, I see that Crutchfield’s Details on the Dragon Tail states

The DragonTail USB-C adapter activates USB Host Mode for newer Android devices, allowing the devices to transmit USB digtal audio to an outboard digital-to-analog converter (DAC).

Does this mean that it’s an OTG cable adapter? I don’t see anything real or more elegant showing up in a search for USB-C to USB-C OTG cable. Everything is USB-C to USB-A

I like the Sabaj well enough, it’s got a somewhat precise way of working with a rather detailed menu system. And I know that USB-2 is just fine for audio. But it annoys me that I can’t just use a proper USB-C cable with it and need to go through some adapter.


Though I expect any proper USB-C to A adapter will also work.

Yes, so do I. I guess with the proliferation of USB-C cables, nobody has made one that does it all within a single USB C to C. It’s like a python that has swallowed a rabbit, gotta have that C to A to C bulge in there.

I share your frustration with this implementation (my participation in this endeavor is partially selfish as I was thinking trying out the Sabaj a20d 2022, but the experience you and others are having with USB-C to USB-C connections gave me pause). I found two USB-C to USB-C OTG cables that appear reputable and are available from a US retailer:

The former has some reviews of it being used with an iPad and a Fiio KA3 (but does not specify which model iPad). The latter doesn’t have any reviews. Hopefully one or both of them will provide a single-cable solution. If you’re happy with the adapter, I would stick with that as it’s a known, working setup, but one of these cables might be worth the chance.

1 Like

Ahehe nice image! :smiley:


1 Like