Equalizer APO/Topping drivers/ASIO drivers not working together

Hardware/software involved:
Lenovo Ideapad 520 (USB 2.0 output/Windows10)
Topping DX3 pro (USB input)
headphones
Equalizer APO/Peace
ASIO audio drivers
Topping USB drivers
Foobar2000 with foo_input_SACD component installed

I’ve been using Equalizer APO/Peace for some weeks now. I really like the results. It worked absolutely fine … until I noticed that I only got 16bit/48Khz output trough my USB connection to my Topping DX3 pro DAC/amp.
I don’t have that many high-res audio files, so it took some time to notice it.
To fix it I installed the Topping drivers and followed the instructions included in the setup documentation found on the official Topping website. These instructions include the installation of ASIO drivers to enable DSD playback using foobar2000 (which is my favorite audio player anyway).
All works fine. I can send high-res PCM and DSD over USB to the Topping now. Playback happens without issues… except for Equalizer APO. It looks like the app is completely bypassed.
I checked to see if all devices are enabled. When playing high-res PCM files I can see the topping in the device list. (clicking"C" next to the evice selection dropdown box) Selecting it has no effect. When playing back DSD, the Topping doesn’t even show up in the device list.
Looking at the “peak value meter” at the bottom of the GUI (peace) it looks like the audio doesn’t even arrive at the app. There’s no signal.
Does anyone know how to fix this?

Equalizer APO works within the Windows sound framework (non-techie oversimplification).

When using ASIO the Windows framework is bypassed so unfortunately equalizer APO will not work.

You can try WASAPI if that is an available output option. Equalizer APO will work and the dac might also be set up for hi res files.

2 Likes

You could do your equalisation inside Foobar and then you can use ASIO no problem.

There are a few parametric EQ VST’s that work in Foobar without issues. There is a thread on the forum (sorry but searching on my phone is a pain) that mention some of them. Personally I use lkjb_qrange.

1 Like

Yeah, I could use the EQ in foobar but they don’t affect the audio from the Spotify app. or other apps. (YT, and other streaming apps/websites)
Now I also noticed that I only get audio out via USB when using Foobar. All other audio plays trough the laptop speakers. :frowning:
So I have some more questions now:

  1. Can I get the Topping to play high-res PCM without the ASIO drivers?
  2. Can I get the Topping to play DSD without the ASIO drivers?
  3. Can Foobar output high-res PCM and DSD to USB without the ASIO drivers?
  4. Can I get other apps to send audio to USB with the ASIO drivers? (it seems that only Foobar does that now)

Edit: I solved the issue with not having any audio output over USB except from Foobar. So Spotify and other audio goes to the Topping OK now. Even Equalizer APO works now with those sources.
I can work with EQ in Foobar in parallel for now. I can save some pressets for each headphone I own.

1 Like

Think of it this way, ASIO is basically a way of the software (in this case Foobar) going directly to the DAC (in this case the Topping) without letting anything else get involved. So no EQ software, or any other software, will be able to communicate with the DAC while Foobar is talking to it via ASIO.

There is also a similar “exclusive” mode in Tidal, for example, that does the same thing, block everything else from interfering with the signal between it and the DAC.

5 Likes

These things can get confusing. For instance, I only use ASIO when routing audio through a DAW. Then I can apply the whole plethora of VSTs out there – including the ones actually being used to make music in these days.

But that would be an expanded scope – not your original question, I admit.

PEACE is a good an easy entry path to DSP, but there are more options out there. :wink:

I’ll go and do a search. A parametric EQ in Foobar2000 would be great!

OK, let’s forget about the EQ for a moment. I’m back to where I get no audio to the Topping except from Foobar.
So, it seems everything works fine (after a windows reboot) until I open Foobar. From then on I can only use foobar. I get no audio to the USB port from other sources (browser, music streaming apps).
VLC does send audio to USB but all high-res files are played back in 16bit/44.1kHz PCM (VLC does not play DSD).
I’m going to uninstall the ASIO drivers and see what happens (I expect the Topping to only play 16bit/48kHz PCM). I suspect the ASIO drivers to mess things up. I hope it’s not the Topping drivers.
If I get all sources to play audio over de DAC again, I start figuring out how to get high-res PCM and DSD playing again.

Edit: Troubleshooting goes fast! I’m still using the ASIO drivers.
So… when I play high-res PCM or DSD audio via FB2k and then switch to the Spotify app for instance, I get no signal to the DAC. When I play an mp3 or flac (16bit/44.1kHz/48kHz) using FB2k first, there is no issue switching to other software for audio playback. So first playing DSD, followed by 1 second of an mp3 using FB2k creates no issue switching to other software for audio playback. Skipping the 1 second of “standard” resolution PCM audio messes things up.
Is this a FB2k issue, a Topping issue, an ASIO issue … ???

Seems like what’s happening is that when playing through fb2k and then exiting fb2k the dac stays in whatever format it played last.

When you play hi-res or dsd in fb2k and then exit, what does Windows settings show for the dac format? If Windows shows 16/44 then other apps like Spotify will think dac is set for 16/44 but it’s really in dsd mode so that could explain why no sound is heard.

As an experiment you could play dsd in fb2k, exit fb2k, in Windows settings change the format to something other than the current setting, apply, then change back to original setting and apply.

The point of this is to force the dac to change formats. Then see if Spotify works.

Also, what output device are you using in fb2k and Spotify. What is the Windows default playback device?

It shows a very funny thing. I’ve got a Dutch language Windows install so I have to translate. It says something like “the output device has been removed.” And indeed “Topping USB DAC” has been removed from the list of output devices. When I close the settings, it returns.

That is certainly not expected.

Unfortunately I don’t have any advice other than the standard uninstall and re-install.

I’d think you’d have to solve the device disappearing problem before the specific issue of sound not working after playng fb2k hi-res.