Wasapi, ASIO, Direct Sound, Oh My!

Hi all - I’ve been using an XD05+ and recently purchased an iFi Zen Dac. In the past I’ve used JRiver and am currently trying Roon. I’ve noticed when using Wasapi (both in Jriver and Roon) I can sometimes hear what I can only describe as faint digital ‘clicks’. Not enough to ruin listening but it does drive me nuts as it’s NOT in the music. I’ve never really noticed the issue when playing music via ‘Direct Sound’. So, my question is, should I be installing separate drivers? Have you experienced this? Should I just stick with direct sound?

I’m going direct from laptop → XD05+ (or iFi Zen Dac which I just sent in for repair). Playing music via JRiver or Roon that lives on my Synology drive mostly in Flac format.

Thanks for the help!

1 Like

When are the clicks happening? Are they definite clicks, or pops, or stutters during playback?

If it’s throughout your music playback and not really corresponding to anything else, check what your playback buffer is set at first, and see if it can be increased. It’s easy to find in Foobar and I believe in JRiver, but I’m not sure with Roon as i don’t have experience specifically with it myself… anyway if you can, set the playback buffer for as long/high as possible since simple playback does not require a short buffer, like say ASIO direct monitoring for recording purposes would. Longer is definitely better for playback.

Also ASIO is not very appropriate for critical listening at all despite what some devotees would claim… WASAPI is meant to be bit-perfect streaming and should handle DSD well too, bypassing everything. But outside of exclusive mode it may not be worth it if it’s causing problems, and Directsound would likely be fine, if it avoids clicks or pops it would be worth using anyway. Also you can EQ with Peace/Equalizer APO when using Directsound, unlike in WASAPI mode so that may be a consideration as well.

If the buffer isn’t the culprit you can look for processes slowing your system down. Trying monitoring RAM, processor, and disk usage during playback. Also check any interference to your external devices. Change USB cables, etc.

Finding and correcting niggling issues like this can truly be hell in a modern OS with many processes/drivers etc all vying for processor time. Short of a reformat and/or setting it up as a devoted playback PC it can very well drive you mad!

I had so many issues with a Dell laptop when attempting to use it as a devoted recording workstation. Despite it’s solid specs it just never worked right for that purpose, and many many hours of specialized setup and ultimately futile diagnosing of these issues later I just had to give up on it. Some PCs just aren’t cut out for certain things it seems. I have an HP that drives me mad with video stutters to an external display. Simple video playback! And I’ve tried basically everything under the sun. But I would hope audio playback by itself shouldn’t be an issue these days…

Good luck though, and report back what you find!


I ran into direct experience with this attempting to use some cloned Amanero USB boards. Turns out, it was the drivers. At least in my experience, the Chinese were able to clone the boards (by using older IC’s), but not the driver software. The actual Amanero USB boards used updated IC’s. Turns out the older IC’s were not perfectly compatible and a steady, annoying click would develop in the audio stream.

This would happen intermittently, which was maddening until I discovered the real reason. It would usually occur after switching from one music selection to another, usually going from 44.1kHz to a higher res, then back again. Nothing would stop the clicking clock sound until I unplugged and plugged back in the power to the DAC.

Solution? I bought the real Amanero boards and never heard the problem again.

This was on the Beezar/ECP Audio Walnut X.1 DAC. I’ve built and sold several of them. Not sure about your XD05, but if there are separate drivers available, you should definitely try them. I hope not for your sake, but it could be that the DAC is not designed to use ASIO. I could be wrong, but I think separate drivers would be required for ASIO at higher resolutions - not sure how it could work, otherwise. I believe the Windows Direct Sound will compensate without additional drivers, but as you’ve probably noticed, it’s not as good or detailed as a “pure” ASIO stream.

I’m far from an expert on these things, but that’s been my experience thus far.


This is all fantastic feedback, thank you!
So clicks don’t seem to be happening at ‘reproducible’ times (I’ve gone back in a track I heard it in and it’s not ‘in the music’) and it almost sounds like a small feint pop almost like I’m playing a record :slight_smile: Definitely not a stutter though.

Trying some more tests while working of using the XD05+ with Wasapi while I’ve got some memory analysis up and I’ve lowered the buffer size to see if that helps at all. So far so good but time will tell as I work more through the day.

Totally with you on the PC side; I’m using my work gaming laptop which should have all the right specs to run well PCs are finicky things.

Thanks again!

Any reason you arent using the specific ASIO drivers? They wont be the same between brands (and sometimes not even between products of the same brand) FWIW

To be honest I haven’t taken the time to look into it. I know my XD05+ support ASIO but I don’t know what/where to get drivers for my PC. OR if it just natively works out of the box with something like Roon and Jriver.

You will need to download the drivers from xduoo’s website (same for the zen stack, you get them from ifi’s site)

I’ve got those :wink: Wasn’t sure if there was something else I needed though to verify that my laptop was ‘using’ ASIO versus just direct sound. I know in Roon and Jriver I can select those as the output and they play fine (Roon is giving me some guff with some of the UI though).

1 Like

oh, got it. Then yes you have them. Are the pops and licks still happening when you are using ASIO output?

Yea I had the issue with my JNOG, it’s the driver. Not sure why it happens, but it did and that was the fix.

Reading an article on the variety of different options your title mentioned with graphs shows really no difference.

I also read an article on sound processing of your pc, if you use windows, to turn that off. It’s in your control panel → hardware and sound → if you click properties under tab 2-3 it says the sound effects of your pc. You can tinker with that and see if you notice any difference.

It said it provides more direct sound to your dac with no influence of idk dsp your pc is making

Make sure to raise the buffer size, not lower it. You don’t need low latency for playback, it adds unnecessary load to the processor and can result in pops and clicks.


Hard to tell with the small amount of listening time I’ve had today. Noticed it once but not as ‘frequent’ as I was hearing before.

I probably didn’t make this as clear as I should have in my post, but you should be using WASAPI drivers with Windows, not ASIO. The rest I described still applies, I believe.


If possible, also try to use the “push” version of WASAPI. There are two types of WASAPI output: “push” and “event”. Some devices aren’t fully compatible with the event version of WASAPI, which can cause issues with playback.


Ok - I’ll look into finding those drivers and give it a test!

So I wasn’t able to figure out / find WASAPI drivers but what I’ve been having success just using the direct sound through my Zen Dac instead of WASAPI or ASIO. The other challenge is that I’m often either hopping in video calls or checking out a video and when I’m using WASAPI/ASIO it ‘takes over’ for my laptop audio overall and I can’t seamlessly switch (have to shut down Roon, etc) back to over. Is this a common issue I’m running into, is there a more ‘graceful’ way around it or just stick with the ‘laptop output’ to me DAC?